miércoles, 8 de junio de 2011

Vlans básico - Cisco

Creación de una Vlan
===================

Si tenemos varios switches lo primero sería definir en un switch de Nivel 3 que haga de Switch principal para enrutar todas la vlans.

******************************************************************************
Alta Configuración VLAN  (En el Core – Nivel 3) Switch Principal
*******************************************************************************
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface vlan 10
Switch(config-if)#ip address 192.168.192.168 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#

----------------
Explicación:
----------------
“interface vlan10”: Creamos la vlan “vlan10”

“ip address 192.168.192.168 255.255.255.0”: le damos un direccionamiento IP a la vlan10 y asignamos una puerta de enlace (192.168.192.168) que habrá que poner en los hosts de este rango que pertenezcan a esta vlan. Si no ponemos este comando no se podrían ver las ip de estos puertos desde otra vlan que no sea la vlan10 y no estaría forzado a ese rango (192.168.192.168).

“no shutdown” : activamos la nueva vlan

---------
Check
---------
Switch# show running-config
Switch# show ip interface vlan 10
Switch# show ip interface brief

-------------------
MSG ERROR
-------------------
Si ponemos la mascara/IP mal normalmente nos devolverá un error:

Switch(config-if)#ip address 192.168.1.0 255.255.255.0
Bad mask /24 for address 192.168.1.0

En este caso al poner una ip acabada en 0 nos da este error (192.168.1.0)



****************************************************************************
Alta – Definición VLAN (Nivel 2) Switch Principal y secundario
****************************************************************************
Switch#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name SalaCPD
Switch(config-vlan)#end

----------------
Explicación:
----------------
“interface vlan10”: Presentamos la vlan “vlan10” con el nombre “SalaCPD

---------
Check
---------
Switch# show vlan


**********************
Baja / Borrar Vlan
**********************
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#no vlan 10
Switch(config)#end

---------
Check
---------
Switch# show vlan

********************
Renombrar Vlan
********************
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#name SalaCPDv2
Switch(config-vlan)#end


*************************************
Alta Puerto para hosts en Vlan
*************************************
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastEthernet 0/2
Switch(config)#switchport mode access
Switch(config)#switchport access vlan 10
Switch(config)#shutdown
Switch(config)#no shutdown

----------------
Explicación:
----------------
En el interface fastEthernet 0/2 solo se podrán conectar ordenadores a la vlan 10 que tenga el rango 192.168.10.0 / 24. Si


*************************************
Baja Puerto para hosts en Vlan
*************************************
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface fastEthernet 0/2
Switch(config)#no switchport mode access
Switch(config)#no switchport access vlan 10
Switch(config)#shutdown
Switch(config)#no shutdown


**********
VARIOS
**********
Si queremos asignar rangos de puertos, por ejemplo desde el puerto 1 al 5, el comando a usar es el siguiente:

Switch(config)#interface fastEthernet  0/1 – 5

También podemos asignar puertos aleatorios

Switch(config)#interface range Gi/10, Gi/12, Gi/14

No nos olividemos de guardar:

Switch(config)#copy running-config startup-config

Probado con Switches de Nivel 3 Cisco 3750 y de Nivel 2 Cisco 2960.

Nota:

Es importante configurar la Vlan a nivel 2 por cada Switch por el que deba comunicarse nuestro hosts contra el que tengamos de gateway de Vlans (nuestra puerta de enlace).

No hay comentarios: